🚧 Scheduled Maintenance
Resolved
May 19, 2026 at 10:25am UTC
Maintenance ended
Affected services
Created
May 19, 2026 at 8:40am UTC
🚧 Scheduled Maintenance
Our services will be temporarily unavailable today starting at 10:40 AM (Montenegro Time) due to maintenance work.
During this maintenance window, we will upgrade the RAM on Montenegro Home VPS Node 1.
At this time, we cannot provide an exact completion estimate. Additional testing and stability checks will be performed after the upgrade before services are fully restored.
We apologize for the inconvenience and appreciate your patience and understanding 💙
Affected services